Moodle requires a web server environment and will run in Apache and IIS easily. Moodle should run in any server environment that supports PHP.
Moodle is written in the PHP scripting language. Currently, Moodle v 1.9.x requires a minimum of PHP v4.3.0 to run. Moodle 2.0 needs PHP v 5.2.8. Moodle 2.1 needs PHP v 5.3.x. There have been some issues with deprecated tags in PHP v 5.3.0 which have a negative impact on a number of PHP Apps, Moodle not exempted, so please ensure your PHP version is later than v 5.3.2 if using a v5.3.x. There has also been reported some issues installing Moodle with PHP-Accelerator. See the PHP Moodle version requirements here PHP settings by Moodle version for more information.
Moodle will use MySQL, MSSQL, PostgreSQL or Oracle as a database, but no others. There is some real issues in the interoperability interface of different databases, which complicates the whole issue. For version information, you can go to the Download page and that will describe version requirements for available packages.
If you want to run Moodle on your own computer, please see Installing Apache, MySQL and PHP for step-by-step instructions for installation on most popular platforms.

Twitter Delicious Facebook Digg Stumbleupon Favorites More

Design by Free WordPress Themes | Bloggerized by Lasantha - Premium Blogger Themes | SharePoint Demo